Mods that recently updated

Oh yeah that is a function in AbstractTree class, that checks if blocks are leaves, logs or air.
It works now, I removed the check for leaves and logs from that function. keeping air for obvious reasons. Don’t want the fungi to spawn inside the ground like Natura does with it’s mushrooms…

But yeah thanks for mentioning that, now Wartblocks have the leaf check and nothing messes with worldgen


Yeah see, that was my problem in the first place when using the config, I couldn’t for the life of me find a way to make the fungal trees get recognized as trees in any way, even with a leaf decay check. Honestly I’m not sure how much of it I’m doing wrong myself, I just tried to copy the mushroom layout (which is working) and using the IDs for warped/crimson logs and wart, but it ain’t working. Even enabling oredict and adding blockWart in the leaves oredict config didn’t work in my test world, it’s the darnedest thing.

I did see in the issue that you’re adding thaumcraft compat for that one axe that cuts down trees though, so unless there’s something glaringly obvious in what I’m doing in my config that can be spotted immediately from miles away for a big happy d’oh moment I’ll just go with that and call it a day really.


Try adding this. It is how Treecapitator detected the huge fungi in my dev version.

netherlicious {

    # This setting controls whether or not the mod config section it appears in will override an IMC message sent by that mod. [default: false]

    netherlicious_stem_1 {
        S:logs=netherlicious:Stem, 1 % 4
        S:leaves=netherlicious:Wartblock, 0 % 8

    netherlicious_stem2_0 {
        S:logs=netherlicious:Stem2, 0 % 4
        S:leaves=netherlicious:Wartblock, 2 % 8

    netherlicious_stem_0 {
        S:logs=netherlicious:Stem, 0 % 4
        S:leaves=netherlicious:Wartblock, 0 % 8

    netherlicious_stem_2 {
        S:logs=netherlicious:Stem, 2 % 4
        S:leaves=netherlicious:Wartblock, 1 % 8


And in the Global config option for Leaf decay it has to be false

    # [Global, PerTree] When true Treecapitator will only instantly decay leaves that have actually been marked 
    # for decay. Set to false if you want leaves to be destroyed regardless of their decay status 
    # (hint: or for "leaf" blocks that are not really leaves). [default: true]

If this doesn’t work it will with the next update. I tried it multiple times. Treecapitator will automatically detect all huge fungi


Speaking of Wood, I found a Bug in your Recipes for Crafting Tables, Bookshelves, (Trap)Doors, Buttons, Signs etc. Some of them are not craftable because the way the Crafting Recipe List is sorted.

You have to add your own personal ShapedOreRecipe class and register it so it sorts before the regular Forge ShapedOreRecipes. (dont worry about NEI, it will work if you just extend the ShapedOreRecipe Class)

Then just take your new own Recipe Class and use it for your variety Wood Recipes, and for the Blackstone Furnace too, while you’re at it.

Here an example of how I do it, slightly modified to fit your case.

RecipeSorter.register("netherlicious:shaped", NetherliciousCraftingShaped.class, RecipeSorter.Category.SHAPED, "before:minecraft:shaped");

This should then finally fix Stuff like the Signs not being Craftable. (The Signs might be the best Test case)

1 Like

Ohhh neat, I’ll try it out. thanks


The recipes work like intended now. thanks again. I replaced a few recipes that way that could get overridden by the ore dictionary.

Btw. is it correct to register the RecipeSorter thing in PreInit?


I guess it is, I do it in preInit too. The important part is that you do it before adding any of your Recipes. Adding Recipes does not have to be done in postInit, it can be done as early as you like, obviously your Items should exist and be registered to the Item Registry when you add the Recipe though. :wink:

One famous case of that being fucked up is Factorization, where the Acid Bottles get registered to the Ore Dictionary before they even got an Item ID assigned, causing CoFH-Core to crash. Luckily Asie fixed that one later on. ^^


Ahhh good. I register my items and recipes in init, but the sorter in pre.

Sometimes registering stuff in the wrong phase works, but has consequences, like registering biomes in Init instead of PreInit. The Biomes will work, but everything that has to do with the Biome dictionary won’t spawn, even if the tags are registered, famous case of that is Enhanced Biomes.

Nice Biome mod but a lot of stuff won’t spawn. Had the same problem for some time before I figured that out


Dont you register Items in preInit like it should be? I am pretty sure you do, because I grab them after your preInit Phase lol.

Edit: Recipes can be whenever, basically, as long as the Items you reference exist when you add those Recipes.

1 Like

Oh wait, I do register them in Pre, I’m stupid :smiley:


So I noticed that you have put §6 in front of your Mod Name, presumably to make it look colorful or something, but all it does is prefixing a “6” in front of Netherlicious during the Loading Bar and in NEI, and it kindof looks bad. It doesn’t break things but it looks like an error. I dont even know where that Color Modifier is actually used, probably in the Loaded Mods Screen, oh wait I looked at that one just now since I had MC open and it is broken there too!, yay.

1 Like

Typing that in German since I can explain it better :smiley:

Die Anzeige der Formatierung ist wohl abhängig vom Betriebs System, zumindest haben Roadhog und ich das wohl letztens herausgefunden, ich ändere das wieder in der nächsten Version. Er hat nen anderes System und in ner anderen Formatierung wurde sein Modname richtig angezeigt in Farbe und bei mir mit ner Zahl davor und bei mir umgekehrt.

Die Farb anzeige ist im Loaded Screen und im Tooltip sowie beim WAILA Tooltip


I do not think it is the OS, it might be the selected Language that does it, or the Version of Java, or the Forge Version, which in my case is English with Oracle Java 8 and Forge 1614. (despite being a German I can understand English better XD)

On the Loading Screen it cannot be properly shows as that one strips the § Sign out of the String without removing the 6, in other things it shows ?6 because the Minecraft Font does not have the § sign in it (since they use that for formatting).

I would like to see a Screenshot of where it actually works properly, since I did not see it so far.

Oh and I do not use WAILA so that might be my Issue. XD

Yeah, I was wondering what the thing with the sign was. For me it never actually worked and it just had that weird sign and number for the longest time until I actually removed that manually in the files months ago.
Not sure how that’s supposed to work, but it’s not even with WAILA.


So I don’t know what happened, I wanted to take a screen and it now displays the name with a weird symbol before the mod name. It worked before. Normally my modname should display in orange that way.
I removed that yesterday and just added it again to take the screen.
But well if it just looks weird for some people I’ll remove that.