Workspace Setup Help?


So, I’m trying to get WeightedInventories and HBM Nuclear to play nicely together in a modpack, but HBM causes WeightedInventories to crash (java.lang.NumberFormatException: For input string: “?”).

I’m hoping to hack at the code to try to fix this (the source of Weighted Inventories is included in the .jar), but I’m having issues setting up the development workspace to do so, thanks to the Forge team setting fire to their own process.

I’ve gone through the setup generously provided at GitHub - OvermindDL1/gt6-new-workspace: Pre-built workspace to make mods for Gregtech 6, but I’m not sure where the decompiled 1.7.10 source code is to link it to the workspace?

I’m a very novice coder. With the help of tutorials, I’ve written some very basic mods, but I’m not very familiar with setting up workspaces.

Any help or suggestions very much appreciated!


Have you tried asking HBM ( @TheBobcat ) for a Bugfix? :wink:

Also maybe try not to give “?” when it asks for a Number.

As for the Workspace did you try running the following in the Console inside the Directory the git workspace is?

On Windows (if i guessed right):
gradlew --refresh-dependencies setupDecompWorkspace build eclipse

On Linux
./gradlew --refresh-dependencies setupDecompWorkspace build eclipse

1 Like

Thanks for the response!

I honestly hadn’t thought to ask HBM for an update - I tend to assume that 1.7.10 projects are abandoned, and I thought it might be easy enough to build out the error handling in WeightedInventories. I’ll definitely ask now though!

You hit the nail on the head with Windows/Eclipse guess lol. I installed Git for Windows and ran the commands in a Git CMD window, but individually in sequence as they are listed in OvermindDL1’s guide. (I tried re-running them as a single command, and didn’t see any difference.) I guess what I expected was to get an “eclipse” folder at the end, where I would point the workspace, but I don’t see one, and I’m unsure how to proceed.


Huh, that’s interesting, in my eclipse workspace it crashes trying to parse “4,5” (despite java using “.” as the decimal separator) and in my MultiMC instance (substantially more mods) it crashes trying to parse “∞”. Can you send me your report just to make sure? I wonder if they have a git repository somewhere because the stacktrace alone doesn’t tell me a whole lot about what’s happening in the background.


Seems like NTM isn’t the only mod that causes it since “∞” still causes parsing issues after removing it from my mod list. I ran the decompiler over WeightedInventories, apparently there’s autogenerated numbers being parsed without checks in place whether these are valid (I assume infinity values turn into “∞” and NAN into “?”). As for the weird “4,5”, that could be a localization issue with java itself, on the CF page there’s comments from the creator about pushing a fix for german clients (hence the “,” decimal separator), but that was in 2018 while the most recent version is from 2017. The creator still seems active though, it couldn’t hurt to ask for a fix or at least the source code so someone else can take care of that.


Yeah Java does not like to parse Unicode properly, so dont expect Infinity to work well.

As for the Git CMD Window, I meant the normal CMD not the git one, just that you had to go inside the Folder of the Git Project. And yes that will make you an eclipse Folder to point the workspace to. :wink:

1 Like

I must be doing something wrong with those commands then - I was getting an error running it in the normal command window and PowerShell, saying it couldn’t run the program “git”, and then it would error out on the setup commands. I’ll give it another shot though, thanks!

@TheBobcat Thanks for taking a look, I really appreciate it! I’ll try reaching out to the mod author of WeightedInventories, though the last comment I saw them leave on an update request made it sound like they were focusing on something else, and wouldn’t work on WI until that was done. (Can’t hurt to ask though!)

The source code for WeightedInventories is actually included in the mod jar file, which is nice.

Here’s my crash report: file io/sBps4nye9eb7 (Says “new users can’t upload files” (or links apparently) when I try to do it direct on here. One day I’ll be cool enough…)


That’s already managed by gradle, so unless you aren’t using gradle in the IDE then it should just work, but if you are then they are some jar in the build directory that gradle creates when you setup* stuff.

Uh, ? is definitely not a number, do you know where that’s coming from?

Fewer than you might think! And for a surprising number of others there are active forks too! The GT New Horizons github has a lot of active forks of various mods, worth checking them first for a lot of things.

Ew? Lol.