Some funky shit is going on with redstone conductor covers

Some funky shit is going on with redstone conductor covers
0

I added 3 distillation towers to my world and put a bunch of redstone emitting and accepting covers in conjunction with activity detectors and redstone machine switches. Now my world opens just fine and then after a couple of seconds it crashes with the following report:

crash-2020-01-13_11.16.31-server.txt (13.8 KB)

It’s hard to identify exactly what’s causing the problem, at the end of the report it also states “OpenGL: ERROR RuntimeException: No OpenGL context found in the current thread

However I have updated my graphics driver and I tried running the world in different java versions with the same result. Any clues would be greatly appreciated.

[11:16:31] [Server thread/ERROR] [FML]: Exception caught during firing event cpw.mods.fml.common.gameevent.TickEvent$ServerTickEvent@4085682d:

java.util.ConcurrentModificationException

at java.util.ArrayList$Itr.checkForComodification(Unknown Source) ~[?:1.7.0_79]

at java.util.ArrayList$Itr.next(Unknown Source) ~[?:1.7.0_79]

at gregapi.GT_API_Proxy.onServerTick(GT_API_Proxy.java:367) ~[GT_API_Proxy.class:?]

at cpw.mods.fml.common.eventhandler.ASMEventHandler_8_GT_API_Proxy_onServerTick_ServerTickEvent.invoke(.dynamic) ~[?:?]

at cpw.mods.fml.common.eventhandler.ASMEventHandler.invoke(ASMEventHandler.java:54) ~[ASMEventHandler.class:?]

at cpw.mods.fml.common.eventhandler.EventBus.post(EventBus.java:140) ~[EventBus.class:?]

at cpw.mods.fml.common.FMLCommonHandler.onPreServerTick(FMLCommonHandler.java:260) ~[FMLCommonHandler.class:?]

at net.minecraft.server.MinecraftServer.func_71217_p(MinecraftServer.java:536) ~[MinecraftServer.class:?]

at net.minecraft.server.integrated.IntegratedServer.func_71217_p(IntegratedServer.java:111) ~[bsx.class:?]

at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:396) [MinecraftServer.class:?]

at net.minecraft.server.MinecraftServer$2.run(MinecraftServer.java:685) [?:?]

Edit: Particularly adding fluid pipes to the exterior of my towers or even wrenching one of my existing pipes, crashes the world instantly I then have to open the world twice for the change to be implemented without instantly crashing.

Setup looks like this:

Edit 2: I recreated the error from scratch in creative I think some funky shit is going on with your covers.

Edit 3: I made a test that show exactly what the issue is:

Setup 1 and 3 works, 2 and 4 causes crashes immediately upon state change. It becomes immediately apparent that the redstone conductor covers fail when you try to connect them through more than two blocks. To be clear in setup 2 and 4 it goes: Lever -> Acceptor cover -> Emitter Cover -> Acceptor Cover -> Emitter Cover -> Acceptor cover -> Emitter Cover -> red alloy wire -> lamp.

4 Likes

Thank you for catching that Bug. I dont know why I did it wrong in the first place, considering there is other near identical code right below it that has it right… Well, its fixed now. ^^

4 Likes