Random 3+ sec pauses

I’ve been having random 3 sec or so pauses. sometimes it will happen shortly after it just happened. I installed Chuck Pregenerator but it made no difference. It’s very annoying.

1 Like

Press F3 and see if your allocated memory (top right) is hitting its limit. If it reaches the maximum when you get the freeze try allocating more ram, but don’t add too much as that can also cause issues.

1 Like

Which kind of Pause are you talking about, is the entire screen freezing or is the game lagging?

If the entire screen freezes for seconds, then you need to lower your graphics settings or at least render distance. Maybe also stay away from Trees, their transparent Leaves love to lag the Game even with Fast instead of Fancy.

1 Like

Yep it was at 100% allocated. I read up and allocated 8GB and now it’s at 58% allocated and 20% to 30% in use.


So trees are evil after all…

1 Like

There was a bug in the lighting engine that i fixed back in versions before 1.7.10, but it didnt quite work for 1.7.10 itself, so i never bothered fixing that fixer mod i had for it back then.

I was having this same issue for weeks and it started driving me nuts, after some digging I solved it by upgrading to an openjdk fork that supports shenandoah garbage collector. That thing is an absolute game changer, increased my fps by levels of magnitude also, and (if you are familiar with somnia) my sleeping multiplier went from ~50x to ~200x

got all the info from a reddit thread, if you search “Upgrade your Java to one that has the Shenandoah Garbage collector. I got 100-200 more FPS” and you should find it

get the jdk8 fork from redhat and enable shenandoah it really is a game changer.