Minor incompatibility between the Autocrafter + Pam's HarvestCraft recipes involving the Cutting Board

So, after a long time playing, I’ve finally crafted my first Autocrafter! After some deliberation, I decided the first thing I wanted to make in it was a Footlong from Pam’s HarvestCraft.

A Footlong requires a Cutting Board or something that can be substituted as one (such as a GT6 Knife or Pocket Multitool (Knife)), as well as the following (or anything that can be substituted for them): Bread, Steak / Cooked Chicken / Cooked Porkchop, Lettuce, Tomato, and Mayo.

So, on my first attempt, I gathered the ingredients for the recipe, then made a Blueprint of it in one of my Advanced Crafting Tables. I used a Thorium Knife for the cutting board, and more-or-less standard ingredients for everything else (Bread, Cooked Porkchop, Lettuce, Tomato, and a jar of Mayo from GT6). I tested to make sure it worked in the Advanced Crafting Table first, then after confirming it did, I scanned the Blueprint to a USB 1.0 Stick in a Scanner. After doing so, I placed the USB 1.0 Stick with the blueprint into the Autocrafter, and it pulled in all the ingredients for the recipe except for the Knife. When I put the knife in there manually, it still refused to craft it.

After that failed attempt, I more or less worked out that the Autocrafter won’t craft any recipes involving manual GT6 tools like the Knife. So I figured, okay, I’ll go make a Robot Arm Blade Tip. I did that, placed it in the Autocrafter's input chest, and the Autocrafter wouldn’t pull it in as input. So, I went back to the Advanced Crafting Table and tried to make a new blueprint, substituting the Robot Arm Blade Tip for the Knife, and I found that I wasn’t able to. On closer inspection, it appears that while the Knife and Pocket Multitool (Knife) belong to the toolCuttingboard oredict, the Robot Arm Blade Tip does not.

Eventually, I just wound up making a normal Pam’s HarvestCraft Cutting Board, replaced the Knife with it in the recipe, made a new Blueprint, scanned it to the USB 1.0 Stick, and plugged it into the Autocrafter and that finally worked.

Still, I’m surprised the Robot Arm Blade Tip isn’t considered a Cutting Board substitute, since it’s seemingly the robotic equivalent of two other tools that are Cutting Board substitutes. That being said, would you mind changing things so you can use the Robot Arm Blade Tip for Footlongs and other similar recipes? That way, if somebody wants to remove the recipe for the Pam’s HarvestCraft Cutting Board (which has infinite uses) they could without losing the ability to craft recipes involving it in an Autocrafter.


You know, you could have just said “The Robot Arm Knife Tip is not considered a Harvestcraft Cutting Board”, right? XD


I guess I could have, lol. I must like typing a lot considering how often I write up these long winded posts. :sweat_smile:


:gregory: This Version should probably be working for you. ^^

(note 1: The scary sounding Description is only there to make sure people don’t use that Version lightly.)

(note 2: if you use this Version more often, make sure your Browser didn’t cache the Download)


Confirmed fixed in latest snapshot.