GT6 TileEntities have chance to disappear in multiplayer

GT6 TileEntities have chance to disappear in multiplayer
0

This is an old bug actually. Whenever I use KCauldron/Contigo/Uranium server core to host a GT6 sever, the players reported that TileEntities sometimes disappear when placed down. The only way to solve this issue is by using Thermos server core (which i don’t even know why, it just works). However Thermos is in conflict with another mod I added so I cannot even start up the server with Thermos.

I asked for help to many server core developers but they either don’t support 1.7.10 now or just disregard this issue. Therefore I came for assistance from you Greg. @Gregorious

3 Likes

Oh great that Issue… I don’t even know how this comes to be, nor could I ever test it, especially if it is RNG when it happens.

Why do you even use those Servers? Can’t you just use a normal vanilla+forge Server for this like everyone else? Which Plugins do you need that don’t already exist as regular Forge Mods? All I can really help you with is finding replacements for shitty Server Software btw. I dont know how else I could help.

3 Likes

Maybe you can look at the KC codes instead of GT’s? I know it is kind of not your responsibility regarding this bug but I do need some plugins to host an off-online-mode server…I tried to debug by examing KC’s codes but I really cannot figure out the problem, since I am not familiar with the mechanism of how GT6 deal with tileentities. Again thank you if you really can help and good luck on Machaenetia.

3 Likes

i use setBlock and setTileEntity, so if one of those two are broken there is nothing I can do about it. Those are very important Standard Functions, which should never not work.

Unless your gregtech.log File contains an overlooked Exception I can’t do much on my end there.

2 Likes

I solved this problem by using Thermos Build 53.

2 Likes

Oh nice to know that Build 53 works with whichever Mod conflicted. Might be a nice thing I can tell others with similar Issues, should they pop up. ^^

1 Like

The mod is Terra Firma Craft

1 Like