GT 6.10.05 suddenly crashed world

world crushed, 'cause i used TE2? all logs

1 Like
---- Minecraft Crash Report ----
// Oh - I know what I did wrong!

Time: 13.03.19 13:10
Description: Exception in server tick loop

java.lang.ArrayIndexOutOfBoundsException: -5
	at net.minecraftforge.common.chunkio.ChunkIOProvider.callStage2(
	at net.minecraftforge.common.chunkio.ChunkIOProvider.callStage2(
	at net.minecraftforge.common.util.AsynchronousExecutor$Task.finish(
	at net.minecraftforge.common.util.AsynchronousExecutor.finishActive(
	at net.minecraftforge.common.chunkio.ChunkIOExecutor.tick(
	at net.minecraft.server.MinecraftServer.func_71190_q(
	at net.minecraft.server.MinecraftServer.func_71217_p(
	at net.minecraft.server.integrated.IntegratedServer.func_71217_p(
	at net.minecraft.server.MinecraftServer$

A detailed walkthrough of the error, its code path and all known details is as follows:

-- System Details --
	Minecraft Version: 1.7.10
	Operating System: Windows 10 (amd64) version 10.0
	Java Version: 1.8.0_181, Oracle Corporation
	Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation
	Memory: 1897633048 bytes (1809 MB) / 2985295872 bytes (2847 MB) up to 3774873600 bytes (3600 MB)
	JVM Flags: 5 total; -XX:+UseG1GC -XX:ConcGCThreads=1 -XX:ParallelGCThreads=1 -Xmx3600M -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump
	AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
	IntCache: cache: 0, tcache: 0, allocated: 15, tallocated: 95
	FML: MCP v9.05 FML v7.10.99.99 Minecraft Forge 39 mods loaded, 39 mods active
	States: 'U' = Unloaded 'L' = Loaded 'C' = Constructed 'H' = Pre-initialized 'I' = Initialized 'J' = Post-initialized 'A' = Available 'D' = Disabled 'E' = Errored
	UCHIJAAAA	mcp{9.05} [Minecraft Coder Pack] (minecraft.jar) 
	UCHIJAAAA	FML{} [Forge Mod Loader] (forge-1.7.10- 
	UCHIJAAAA	Forge{} [Minecraft Forge] (forge-1.7.10- 
	UCHIJAAAA	CodeChickenCore{} [CodeChicken Core] (minecraft.jar) 
	UCHIJAAAA	NotEnoughItems{} [Not Enough Items] (NotEnoughItems-1.7.10- 
	UCHIJAAAA	<CoFH ASM>{000} [CoFH ASM] (minecraft.jar) 
	UCHIJAAAA	BinniePatcher{1.8.2} [Binnie Patcher] (minecraft.jar) 
	UCHIJAAAA	gregapi{GT6-MC1710} [Greg-API] (gregtech_1.7.10-6.10.05.jar) 
	UCHIJAAAA	CoFHCore{1.7.10R3.1.4} [CoFH Core] (CoFHCore-[1.7.10]3.1.4-329.jar) 
	UCHIJAAAA	BuildCraft|Core{7.1.18} [BuildCraft] (buildcraft-7.1.18.jar) 
	UCHIJAAAA	BuildCraft|Transport{7.1.18} [BC Transport] (buildcraft-7.1.18.jar) 
	UCHIJAAAA	BuildCraft|Silicon{7.1.18} [BC Silicon] (buildcraft-7.1.18.jar) 
	UCHIJAAAA	BuildCraft|Factory{7.1.18} [BC Factory] (buildcraft-7.1.18.jar) 
	UCHIJAAAA	additionalpipes{4.7.0} [Additional Pipes] (additionalpipes-4.7.6.jar) 
	UCHIJAAAA	IC2{2.2.827-experimental} [IndustrialCraft 2] (industrialcraft-2-2.2.827-experimental.jar) 
	UCHIJAAAA	AdvancedSolarPanel{1.7.10-3.5.1} [Advanced Solar Panels] (AdvancedSolarPanel-1.7.10-3.5.1.jar) 
	UCHIJAAAA	Forestry{} [Forestry for Minecraft] (forestry_1.7.10- 
	UCHIJAAAA	BinnieCore{2.0-pre14} [Binnie Core] (binnie-mods-2.0-pre14-ru.jar) 
	UCHIJAAAA	Botany{2.0-pre14} [Botany] (binnie-mods-2.0-pre14-ru.jar) 
	UCHIJAAAA	ExtraBees{2.0-pre14} [Extra Bees] (binnie-mods-2.0-pre14-ru.jar) 
	UCHIJAAAA	ExtraTrees{2.0-pre14} [Extra Trees] (binnie-mods-2.0-pre14-ru.jar) 
	UCHIJAAAA	Genetics{2.0-pre14} [Genetics] (binnie-mods-2.0-pre14-ru.jar) 
	UCHIJAAAA	BuildCraft|Energy{7.1.18} [BC Energy] (buildcraft-7.1.18.jar) 
	UCHIJAAAA	BuildCraft|Builders{7.1.18} [BC Builders] (buildcraft-7.1.18.jar) 
	UCHIJAAAA	BuildCraft|Robotics{7.1.18} [BC Robotics] (buildcraft-7.1.18.jar) 
	UCHIJAAAA	IC2NuclearControl{2.4.2a} [Nuclear Control 2] (IC2NuclearControl-2.4.2a.jar) 
	UCHIJAAAA	inventorytweaks{1.59-dev-152-cf6e263} [Inventory Tweaks] (InventoryTweaks-1.59-dev-152.jar) 
	UCHIJAAAA	NEIAddons{} [NEI Addons] (neiaddons- 
	UCHIJAAAA	NEIAddons|Developer{} [NEI Addons: Developer Tools] (neiaddons- 
	UCHIJAAAA	NEIAddons|AppEng{} [NEI Addons: Applied Energistics 2] (neiaddons- 
	UCHIJAAAA	NEIAddons|Botany{} [NEI Addons: Botany] (neiaddons- 
	UCHIJAAAA	NEIAddons|Forestry{} [NEI Addons: Forestry] (neiaddons- 
	UCHIJAAAA	NEIAddons|CraftingTables{} [NEI Addons: Crafting Tables] (neiaddons- 
	UCHIJAAAA	NEIAddons|ExNihilo{} [NEI Addons: Ex Nihilo] (neiaddons- 
	UCHIJAAAA	ThermalFoundation{1.7.10R1.2.6} [Thermal Foundation] (ThermalFoundation-[1.7.10]1.2.6-118.jar) 
	UCHIJAAAA	ThermalDynamics{1.7.10R1.2.1} [Thermal Dynamics] (ThermalDynamics-[1.7.10]1.2.1-172.jar) 
	UCHIJAAAA	ThermalExpansion{1.7.10R4.1.5} [Thermal Expansion] (ThermalExpansion-[1.7.10]4.1.5-248.jar) 
	UCHIJAAAA	gregapi_post{GT6-MC1710} [Greg-API-Post] (gregtech_1.7.10-6.10.05.jar) 
	UCHIJAAAA	gregtech{GT6-MC1710} [GregTech] (gregtech_1.7.10-6.10.05.jar) 
	GL info: ~~ERROR~~ RuntimeException: No OpenGL context found in the current thread.
	CoFHCore: -[1.7.10]3.1.4-329
	ThermalFoundation: -[1.7.10]1.2.6-118
	ThermalDynamics: -[1.7.10]1.2.1-172
	ThermalExpansion: -[1.7.10]4.1.5-248
	Profiler Position: N/A (disabled)
	Vec3 Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
	Player Count: 1 / 8; [EntityPlayerMP['BayCat'/273, l='New World', x=1208,35, y=69,00, z=-113,75]]
	Type: Integrated Server (map_client.txt)
	Is Modded: Definitely; Client brand changed to 'fml,forge'

Okay, good news is, its not the Mod List, bad news is, I dont think this can easily be solved, as it could be a Forge or vanilla MC Issue.

My only hope for this specific Type of Crash is, that it only happened once and wont happen again if you launch the Game again.

But seeing you have two crashes, I guess it will repeat over and over, because one of the Chunks somehow got corrupted, try deleting the one Chunk that you last placed a Block in, maybe that helps, because this looks like something got an invalid Block ID.

1 Like

i don’t know how to do it ._.


I have never needed to actually remove specific Chunks myself, so I dont really know. All I know is using MCEdit probably helps, but I never used that either. I’m gonna summon some people here who might be able to help better.

@OvermindDL1 @SuperCoder79 @Qwerty @Speiger

1 Like

once I tried use MCEdit for world with this mod, and… maybe cause my computer too slack, heh
my friend think, anvils crashes the world.


Yeah that just looks like flat-out world corruption there. If you have a backup then pull that chunk from your backup. Otherwise MCEdit ‘might’ be able to do it (although honestly I would expect it to not handle this, maybe crash too or just corrupt it). Otherwise you can start binary editing things but that’s a pain and significantly “not easy”. ^.^;

I’d say just take each region from backup and restore it until you find the one that caused it.

And if you don’t have a backup, then your only option then is to delete the chunk and/or region. Remember to always back up, make it part of your launch script or use the AromaBackup mod or whatever it was to automate it!

1 Like

Chunk Pregen has a feature to delete chunks live from the running server (if they are unloaded) from the disk. As long you know where its coordinate where it is.

This is the mod that can do it:
(server only needed)

/pregen delete deleteChunk
Description: Deletes a Single Unloaded Chunk
X Position: The X Chunk Position of the Deletion. (if ‘b’ infront of the number or after ~ means block position)
Z Position: The Z Chunk Position of the Deletion. (if ‘b’ infront of the number or after ~ means block position)
(Optional) Dimension: The Dimension the Deletion should be happening in
(Optional) Delay: How long the Deleter should wait until it should start (in ticks)

/pregen delete deleteChunk 100 200

  • Deletes a Unloaded Chunk at X100 Z200 at the Dimension that the sender is at

/pregen delete deleteChunk b100 b200 -1 200

  • Deletes a Unloaded Chunk at X6 Z12 in the nether and waits 10 seconds until starting it

As long the chunk is not loaded it can delete it. (it wont load the chunk it just tries to delete the data at the position.