Exception in server tick loop

---- Minecraft Crash Report ----
// But it works on my machine.

Time: 6/26/19 7:28 PM
Description: Exception in server tick loop

java.lang.ArrayIndexOutOfBoundsException: -2
at net.minecraft.world.chunk.NibbleArray.func_76582_a(SourceFile:26)
at net.minecraft.world.chunk.storage.ExtendedBlockStorage.func_76665_b(SourceFile:75)
at net.minecraft.world.chunk.Chunk.func_76628_c(Chunk.java:548)
at net.minecraft.world.chunk.Chunk.func_150812_a(Chunk.java:878)
at net.minecraft.world.chunk.Chunk.func_150813_a(Chunk.java:862)
at net.minecraft.world.chunk.storage.AnvilChunkLoader.loadEntities(AnvilChunkLoader.java:500)
at net.minecraftforge.common.chunkio.ChunkIOProvider.callStage2(ChunkIOProvider.java:41)
at net.minecraftforge.common.chunkio.ChunkIOProvider.callStage2(ChunkIOProvider.java:12)
at net.minecraftforge.common.util.AsynchronousExecutor.skipQueue(AsynchronousExecutor.java:344)
at net.minecraftforge.common.util.AsynchronousExecutor.getSkipQueue(AsynchronousExecutor.java:302)
at net.minecraftforge.common.chunkio.ChunkIOExecutor.syncChunkLoad(ChunkIOExecutor.java:12)
at net.minecraft.world.gen.ChunkProviderServer.loadChunk(ChunkProviderServer.java:126)
at net.minecraft.world.gen.ChunkProviderServer.func_73158_c(ChunkProviderServer.java:101)
at net.minecraft.server.MinecraftServer.func_71222_d(MinecraftServer.java:265)
at net.minecraft.server.integrated.IntegratedServer.func_71247_a(IntegratedServer.java:78)
at net.minecraft.server.integrated.IntegratedServer.func_71197_b(IntegratedServer.java:92)
at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:387)
at net.minecraft.server.MinecraftServer$2.run(MinecraftServer.java:685)

A detailed walkthrough of the error, its code path and all known details is as follows:

– System Details –
Minecraft Version: 1.7.10
Operating System: Windows 10 (amd64) version 10.0
Java Version: 1.8.0_51, Oracle Corporation
Java VM Version: Java HotSpot™ 64-Bit Server VM (mixed mode), Oracle Corporation
Memory: 783480448 bytes (747 MB) / 1610612736 bytes (1536 MB) up to 4294967296 bytes (4096 MB)
JVM Flags: 8 total; -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump -Xmx4G -XX:+UnlockExperimentalVMOptions -XX:+UseG1GC -XX:G1NewSizePercent=20 -XX:G1ReservePercent=20 -XX:MaxGCPauseMillis=50 -XX:G1HeapRegionSize=32M
AABB Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
IntCache: cache: 0, tcache: 0, allocated: 12, tallocated: 94
FML: MCP v9.05 FML v7.10.99.99 Minecraft Forge 8 mods loaded, 8 mods active
States: ‘U’ = Unloaded ‘L’ = Loaded ‘C’ = Constructed ‘H’ = Pre-initialized ‘I’ = Initialized ‘J’ = Post-initialized ‘A’ = Available ‘D’ = Disabled ‘E’ = Errored
UCHIJAA mcp{9.05} [Minecraft Coder Pack] (minecraft.jar)
UCHIJAA FML{} [Forge Mod Loader] (forge-1.7.10-
UCHIJAA Forge{} [Minecraft Forge] (forge-1.7.10-
UCHIJAA CodeChickenCore{} [CodeChicken Core] (minecraft.jar)
UCHIJAA NotEnoughItems{} [Not Enough Items] (NotEnoughItems-1.7.10-
UCHIJAA gregapi{GT6-MC1710} [Greg-API] (gregtech_1.7.10-6.10.22.jar)
UCHIJAA gregapi_post{GT6-MC1710} [Greg-API-Post] (gregtech_1.7.10-6.10.22.jar)
UCHIJAA gregtech{GT6-MC1710} [GregTech] (gregtech_1.7.10-6.10.22.jar)
GL info: ERROR RuntimeException: No OpenGL context found in the current thread.
Profiler Position: N/A (disabled)
Vec3 Pool Size: 0 (0 bytes; 0 MB) allocated, 0 (0 bytes; 0 MB) used
Player Count: 0 / 8;
Type: Integrated Server (map_client.txt)
Is Modded: Definitely; Client brand changed to ‘fml,forge’

Game ran fine for a few days then one day it won’t load a world at all. Can’t figure out the exception

Tried allocating more memory to Java in launcher.

Tried raising the number of chunks a mod can force in the forgechunkloading config

Tried updating java, couldn’t make it run without the Microsoft version they baked in to the new launcher, due to how inept I am. lmfao.

Out of ideas. Any help would be appreciated.


Holy crap that’s a bad World Corruption you have there. Where are you at? Newly generated terrain? If so maybe delete the region File that corresponds to the chunks you are around at right now. And MAKE A BACKUP BEFORE.

@OvermindDL1 any idea what this could be about btw?


What causes world corruption? It’s happened to me before on another machine. Should I make world backups regularly?


I dont actually know how it happens, sorry.


I lean to world corruption on that as well, and lots of things can cause it, Minecraft’s file writing is a bit subpar. This is why routine backups should always be done (I used Aroma Backup back in the day if that’s still a thing?).


Ah good, thanks for marking it as a Solution (otherwise I would have had to move this Issue somewhere else to make the Auto-Bump stop), I hope it at least saved your World from the current Corruption. ^^