Electric wrenches, mode switching

Hey Greg.
I have a small problem with the electric wrenches. Sneak/shift + right clicking seems to unconditionally switch between wrench/monkey wrench mode, for me…
As wrench sneak+right click is often used for various interactions in other mods it’s a bit of a bummer…
Shouldn’t the electric wrenches first try normal actions when sneak+rclick on some block/te, only doing the mode switch if that did nothing?

1 Like

Wait what exactly is the Issue, does the Mode switching prevent Wrench usage?

And does this only apply to Buildcraft Wrench Compatibility? Because GT6 Stuff should allow Sneak Rightclicking just fine on Machines.

yes, correct. you just end up switching back and forth between wrench/monkey wrench mode instead of interacting with the block.
and it’s on BC wrench compat (it’s often used for dismantling pipes, tanks, machines, etc, on other mods (is there even any GT6 machine/block that reacts to wrench sneak+rclicks? it’s usually only rclick to rotate or hold left to break when it comes to gt6 wrench interactions…))

1 Like

Gah, that’s gonna be annoying to fix, because BC Machines are “Block React to Rightclick -> Check if held Item is Wrench”, while GT6 Stuff is “Item React to Rightclick -> Do Stuff to Block that has been clicked”

Edit: wait a sec, cant my wrench leftclick Harvest BC Pipes? (I mean specifically those, I know other Mods would not work with that)

Testing…
Yes, left click on a pure cobblestone BC pipe harvest it (I wasn’t aware of that one…)

1 Like

Yeah I made a special case that is able to harvest any Buildcraft Block with the Wrench, as long as its not a Liquid Block (aka Oil)

I will do something about your Issue in the next Release for sure, and it should work with all wrenchable other-Mod TileEntities at the very least. ^^

1 Like

:gregory: This Version should probably be working for you. ^^

(note 1: The scary sounding Description is only there to make sure people don’t use that Version lightly.)

(note 2: if you use this Version more often, make sure your Browser didn’t cache the Download)

1 Like

I assume that Like means it works, so I can mark this as solved?

Apologies; didn’t realize you were waiting for confirmation.
Yes, solved. Thank you, Greg. And Merry Christmas :christmas_tree:

1 Like

Yes having the Forums Auto-Ping your Thread kinda means its open ended. XD

Merry Christolidays or so. XD

Hrm, actually… When I’m in survival mode and right-click with a GT cropanalyzer or portable scanner they get turned into the GT creative debug scanner.
I’m gonna assume the behavior switch changes are somehow behind this since it was working correctly some weeks ago.

1 Like

the fuck WHAT?!?!?!?! that is not supposed to happen at all, they dont even have a mode switch!

Edit: Found the Issue, will be fixed in the next build. Should be ready in ten minutes or so.

1 Like

Thanks, seems to work correctly now.

1 Like