Advanced crafting table fubar

So I just made some more ladders in the advanced crafting table. I distributed a bunch of sticks across the H shape, and when you click to craft the ladders, it prefers to pull all of the sticks from one slot, leaving it empty and the remaining slots still full so you can’t make but one or two ladders and have a bunch of leftover sticks you have to pick up and redistribute again.

1 Like

Wait what?! I literally just fixed an exploit bug related to that…


:gregory: This Version should probably be working for you. ^^

(note 1: The scary sounding Description is only there to make sure people don’t use that Version lightly.)

(note 2: if you use this Version more often, make sure your Browser didn’t cache the Download)

Yea yea… supersecret download… testing now.

1 Like

So the numbers in each slot still go down really wonky if I click one craft at a time, but it at least never leaves one slot empty and I think I ended up with the right number of ladders.

1 Like

Yeah it consumes from the crafting grid first but always leaves 1 in the slots. That’s a major improvement for many common cases.

What was wrong with just taking one from each slot?

1 Like

Nothing, I basically fixed that in that Build I linked to you on the Sound Thread you made. It basically does exactly the same but it tries to take from the proper slots first.

Like I said, it still seems to take from the top left slots first and only from the other slots when the slot before is down to only one left.

1 Like

Uhh I am pretty sure I fixed that in the same build as the one where I fixed the popping noise. Did you test it with that Build?

I tested it last night when you said you fixed it and I said that yes, it no longer completely empties the first slot and stops you from crafting more, but instead takes the first slot down to 1, then moves to the next slot until it is down to 1, and so on. I did make some more ladders just now with the popping fix and I think it worked the same, but I wasn’t paying close attention.

1 Like

Well uhh, do you need more Ladders? XD

right now that table should go in this order:

  1. Take from Adjacent Storage Blocks.
  2. Take from the Slot the Item is inside of, as long as the Stacksize is greater than 1.
  3. Take from the other Crafting Grid Slots, as long as they are greater than 1 too.
  4. Take from all the Storage Slots.
  5. Consume the remaining single Items from the Grid.

Oops… I put 5 sticks in each slot and made one batch of 3 ladders… only the top left slot had a stick deducted from it, the rest still had 5. I kept making more and each time it subtracted only 1 stick from the top left slot until it reached 1, then started subtracting 1 stick from the next slot.

1 Like

I just made 4 item barrels. I prepared 16 treated wood planks and 8 long iron rods. Now I have 5 item barrels and 8 treated planks and 6 long iron rods left over :wink:

1 Like

What the… that isn’t supposed to be happening. And you did not put anything in the storage slots?

Okay in this Test Version I got it to work without duping. See link further above. ^^

Much better :slight_smile:

Derp derp derp minmum post length.

1 Like

I now have a problem: when using an advanced crafting table to crafting recipe that requires a bucket of fluid like fire bricks, the vanilla bucket cannot be stacked because they don’t support drums. As a result, every time you crafting, you have to exit the GUI and manually fill the buckets with water. Then when entering, it is impossible to directly crafting in batches, which is too troublesome.
Can the advanced crafting table support the drums to participate in the recipe with fluid? Or, put the drum in the fluid slot in the upper right corner (I don’t know why these slots are designed) to automatically replenish the fluid?

1 Like

Okay this is a complicated question to answer, also please answer to my chemical question on the other thread you opened too please.

If you directly pipe the Fluid into the Table, it will refill the Buckets.

If you have a Drum next to the Table, it will try to replenish Container Items with its Fluid too, directly while crafting, even with shiftclicks.

I just looked at the code and did find an Error there, so that might be the source of Water vanishing while the bucket is consumed without a trace, which is clearly a Bug that is gonna be fixed with the next test build.

Ah I knew there was a way, couldn’t remember how to do it.

1 Like