A possible bug about empty nuclear reactors

I tried an empty 2X2 nuclear reactor in GT6.14.20 in order to watch its explosion, then I found an interesting thing.

STEP1: I built a 2X2 nuclear reactor which keeping no coolant and filled it with two kinds of fuel rods.
I used the cover and lever to turn the reactor on.

Green:U235 fuel rod
Blue:Empty rod

STEP2: I used another empty rod to right click with the empty rod.
Then all existing rods disappeared.

STEP3: I used other rods to fill the reactor.
However, they disappeared, too.

The amount of Co-60 fuel rod has reduced from 14 to 10.

Turning off the reactor to fill it will not affect the disappearance.

STEP4:I destoryed the reactor, then nothing dropped (except the lever).

I tried several times, then got a possible law:

  1. Nuclear reactor must be empty and open.
  2. There should have two or more fuel rods with “This Fuel is Critical”
  3. Interacting with the existing rods with rods is essential.

I guess I need to tell @Erik3003 that something is wrong again.


This one is not my doing, it’s not really a bug either :grinning_face_with_smiling_eyes:

The reactor has “exploded” or rather is constantly exploding each tick (because the heat in the reactor never decreases below explosion territory) and removing the rods (but not updating the model), but Greg disabled the actual explosion that would remove the reactor block (and surrounding area) entirely “until Reactor System has been tested well enough” (MultiTileEntityReactorCore2x2.java, line 204).

The easy fix is to re-enable the explosion of the two reactor blocks.